Android menu button not working (4.4.2)
  • Hi there!

    I've downloaded the app a while ago for my Nexus 5 running on stock Android 4.4.2 KitKat. Everything looks fine, map downloads went quick etc.
    But I can't get to click that 3 stripes button which is supposed to be the menu/options therefore I cannot do anything with the app! It just won't do anything when I touch it. I tried force stopping the app and restarting it but it still doesn't work.

    Do you guys have any solutions to that problem or any tips?

    Thanks in advance,
  • 8 Comments sorted by
  • The Android menu button is not supposed to do anything at all. Does nothing on 4.2.2 also.
    You should control the navigator app with the 9 buttons provided by the app on the screen:
    Search, Navigate, Routing info, My places, Tools, Map
    and on the bottom line:
    Settings, map manager and close

    There is nothing else.


  • We didn't understand each other. I know that those 3 bottom Android buttons won't do anything in the app. I meant the button just above those system ones. Also, I have only the settings button, no map manager and close. But it doesn't do anything when I click it. I tried installing the newest version, it didn't work.

    Here's a screenshot (if anyone wondered, it's in Poland):

  • Sorry for the misunderstanding.
    But I simply don't have those 3 stripes on my Android 4.2.2.
    This screen line is only showing "Waiting for good GPS signals" when the GPS has not yet acquired a position or is unavailable, otherwise empty.
    I'm using Navigator free 1.2.39
    Better wait for someone from MF.


  • @tomas, I have done that but it didn't help.
    So what should happen when I click the three-stripes button?
  • three-stripes button appears when there is no hardware Menu button
    it should come with Menu

  • What happens when you turn your phone to landscape mode?

  • В главном меню Вашего Андроида выберите "настройки"/"приложения"/ "Навигатор"/
    В открывшемся окне в разделе "память" нажмите "стереть данные". Ваша "3 stripes button" должна заработать.

    In the main menu of your Android, select "Settings" / "application" / "Navigator" /
    In the window that opens, in the "memory" click "delete data". Your "3 stripes button" should to make.
    Sorry for my English.

  • I installed Navigator on my tablet running KitKat 4.4.2. The "graphical menu" was enabled by default, but I thought I'd try switching it off to see what happened. I now know why it was enabled by default: without it, the menu button does nothing.

    After a while trying to fix this, I decided to clear the data. Now I'm re-downloading the maps... now done. That was a way to fix it, but I'd hoped to find an easier way!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion