Build-in GPS (Windows Tablet) doesn't work with Navigator
  • Hey,
    i just wanted to install Navigator on my new Windows Tablet (Windows 8.1 pro), Lenovo Miix 2 8, which has a build-in GPS, like many others new tablets have now aswell, but the software just doesn't work with it. It only looks for GPS sources at COM Ports, not at build-in ones.

    Can you add the support of build-in GPS Chips? Think more and more Tablets/Netbooks/Notebooks will have them, right now there are already quite a bit out there and more are coming
  • 10 Comments sorted by
  • Hello,

    You could try this "Centrafuse Localizer 4" from here:
    This program was mentioned on this forum: 
    Problem is to find a tool that transfers the data from serial API sensor to a (virtual) COM.

  • Hey thanks, already found that programm, but it costs 15€ for something, which i hope will soon be implemented into the software?
  • I have the same Tablet but from a previous installation on a Netbook, I had the BT 338 device sold by Directions, so I am using that with no problems
  • So you just have another GPS device as the solution or am i missunderstanding something? :(
  • No, you are correct.
    I also tried to get somewhere by researching the connection problem but got nowhere and as I happened to have the Receiver lying around I used that.
    I have noticed that Maplin are doing a GPS Dongle for £29 which will work, cheaper than the BT338 Device.
    I should point out that I have the "Paid For" version of Navigator 12.
  • So thats why i posted this in "Feature Request", i mean there are will be even more users with a buid-in GPS, that are all looking for a navigation App and the fix programm from centrafuse just cant be the solution? Please implement them in the next version !
  • I have a Sony Vaio Duo 13 with GPS inplace too.
    SOLTION: Download the "SensorDiagnosticTool". Start the tool and wait to, the inplace GPS (e.g. HUAWEI GNSS Sessor) logs GPS data - not the "Windows postionsdata"!. Atfer then, start MapfactorNavigator Free and select the inplace GPS. Just, you have the GPS in MapFactor on your map.
  • Correct me if I am wrong but this is not a gadget issue. Ass people posted above advice, this is a problem with programs installed on a tablet. A lot of these gadgets that are half computer, half phone do act like mobile tracking software, but there is a lot of program incompleteness.
  • why don't you install Mapfactor Navigator from Windows Store ?
    that supports internal GPS
  • Have you tried factory reset or satellites connection configuration? Might help. Sometimes the issue can be solved via installing iphone spy app which has built-in custom configurations for navigation. Give it a shot. Hope it's helpful for you (:

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion