Navigator Android crashes when I start it
  • Hi all,

    I have a Sony Xperia xz1 compact (Android 9) since the last map update (I think) the Navigaort crashes when I start the the app. I already reinstalled the latest version, download the maps several time.
    In a few cases it shows that maps are damaged and asks to delete these maps.  When I click OK, crashes after deleting these maps.

    When I tried to start the app after deleting the demaged maps it tries to check the map data, then it shows "data is ok" after I click "OK" it crashes again.

    What can I do to get back a working Navigator on my phone?

  • 17 Comments sorted by
  • Hi Michael,

    close Navigator and Clear data in Android settings > application manager > Navigator - then reboot your phone.

    folder android/data/com.mapfactor.navigator/files/navigator/

  • Hi Tomas,

    thanks for your tip... I just tried it... no changes.

    I could start Navigator, than I download the maps (Denmark and whole Germany), after downloading and after the app goes back to the start screen the app crashes. Restarting the app it ased for checking data, found one defectiv map, deleted it, than "OK" and crashed again.
    X( :((

  • please send logs from settings/advanced if you can access Navigator
  • Hi Tomas,

    I don't get acess to Navigator. When I try to open it, it wants to check the map files, after clicking SART I get the information, that there are no problems, when I click OK the Navigator try to start and crashes again.

    Is there a possibility to get the log files directly out of the memory? If so which files shall I send and could you tell me the path?

  • Sounds like you may have to delete the app and start over. Cn you connect the phone to a computer and access the files and  make some backups of the files you may lose, like my places etc.? 
  • Hi,

    For information I have been the same problem for a year now, on a Galaxy S5 Marshmallow 6. Navigator often crashs, or not, at start up during the map verification : "Navigator quit", so I restart one or two times and it's OK. Clearing the cache helps sometimes even without restarting the S5.

    One thing more, if I start with wifi on, it crashs the same way. If I want to check maps update, I've to start first and then set the wifi on. This way is always good.

    I also have Navigator on a Galaxy S7 Oreo 8 without that crash, so I consider my "old" S5 set is perhaps the reason. Anyway Navigator and the S5 are my main GPS and I couldn't navigate without my favourite !
  • Hello,

    first of all, the favorites are not important for me.

    I just tried a new installation of Navigator. Clearing the app cache, clearing app data uninstalling the app. Then I reinstalled the app. Started the app, download a few maps. After downloading the maps Navigator tiried to go back to the start screnn and closed itself. :-(
    Than i did the same as above, but after the uninstalling I searched for "mapfactor" in the main memory and deleted the folder. Same I did at the SD card.
    Then I installed Navigator again and it works. The app was installed in the main memory. To save memory space I choose SD card for Navigator data files. The app copies the data and afterwards the app coled itself and it was not possible to restart it. Evertime it crashes when the start screen is loading.
    So I uninstalled and delete again and made a new installation. 

    I think that phenomen is a bug. It's really worse when it's not possible to store the map data files at the SD card. Please find a soloution quickly. 
    Memoryspace in the main memory is rare and it's not very comfortable to delete maps I don't need at the moment and download maps I need because of the limited main memory. 

    Maybe you can try my way to make Navigator work? It would be ineresting if it works in your case too. 

    Best regards
  • if it works in internal storage and not on SD then there could be two reasons:

    1. you are using Android to move Navigator to SD, please use feature in Navigator settings/map manager, Android does not do it properly

    2, your SD is faulty or fake - fake is a card which pretends to be of higher capacity than it is
    you can test it by simply copying files to SD to full capacity and then copy back to PC
  • Hi Tomas,

    thanks a lot for your weekend reply!

    1. ofcause I have used the Navigator function. ;)

    2. Hmmm... I know that it works with that SD-card in the past. So the only possiblility is a demanged SD card.

    Could you (or someone else) tell me if it should be possible to copy the data from the current SD card (without any Navigator data) to my computer via a USB connection and then insert a new card into the mobile phone and copy the saved data back to the new SD card after formatting?

    ...and if so, does this also work if the new SD card has less or more storage space?

    Best regards

  • You may want to check out the health status of your SD card first. See . Shouldn't be a problem to transfer data over, but check your specs for the largest SD card you can use. I have transferred pictures and music over with no problems . 
  • Hi Charles,

    good idea! I will try that first.


  • you need to download at least one map, try Andorra, it is very small
  • Hello to all,

    I think I'm starting to get stupid. :((

    I tested the SD card... both Windows tools did not detect any errors. Here is the result of chkdsk:

    C:\WINDOWS\system32>chkdsk Z: /f
    The file system type is FAT32.
    Volume serial number : F0E9-334E
    Files and folders are scanned...
    The file and folder check is complete.

    File system has been checked, no problems detected.
    No further action required.
     131,007,552 KB total storage space on the disc
     128 KB in 2 hidden files
     13,696 KB in 214 folders
     3,390,144 KB in 1,970 files
     127,603,520 KB are available

     65,536 bytes in each allocation unit
     2,046,993 allocation units on the data carrier in total
     1,993,805 allocation units available on the data carrier

    Then I reinserted the SD card into the mobile phone, started the mobile phone, opened Navigator and since then I no longer have (or can no longer find) the menu item for selecting the storage location. - It can't be that it suddenly no longer exists, can it?

    Even a complete reinstallation has not changed anything. I seem to remember that MF asked for the storage location when I first started the app yesterday, but not today... but maybe I'm mistaken.

    I'll take Denmark for testing. It's also relatively small and I need it anyway.

    Best regards
  • For installing maps to SD card. Touch settings, map manager and scroll down for installation to SD card or internal
  • Good morning,

    That's the way I remember,but now it's getting spooky...

    I have installed Navigator 7.3.51 at three Andriod units and I'm a premium-function user for 3 or 4 years. So I'm no newbie with the Navigator.

    1. Sony XZ1 compact (G8441) with Android (my mobile Phone)
    2. Lenovo Tablet TB-8505XS with Android 10 (my normal car use sat-nav system)
    3. Lenovo TAB M10FHD Plus with Android 10 (my home Tablet)

    At all units there is no possibility to choose the location for storing the map data.

    I just have (I translate to English)
    1. Download Maps
    2. Delete Maps
    3. Buy Maps
    4. Import Map Data
    5. Map Data Source
    6. Type of Download
    7. Checkbox: Check for Updates
    8. Checkbox: early access to Maps
    9. Rate and comment on Maps (is ghosted)

    That's it and it's the same on all of the three units and the two Tablets are working fine ans I have nothing changed (apart from updates).

    What is wrong?


  • your SD is not inserted or not mounted, possibly corrupted
    you can check in Android settings > Storage

    to be honest, I think you could save a lot of time by buying a new branded SD

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion