Does the company still exist?
  • Hi,
    I finally upgraded from Android 7.1 to a new phone with Android 13 two weeks ago, and in the next few days tried out my 250+ apps one by one.

    Navigator told me about a licence problem - "cause is frequently a new Android version" and asked if I wanted to solve the problem, which I did.
    I was told there should be a solution within 24 hours.

    I waited two days, started Navigator, same message.

    Since then I have been starting Navigator once a day - always the same message (to which I always reply, re-sending my email address as required by the second message, after I tapped on "Yes").

    What's going on?
  • 5 Comments sorted by
  • we received your requests, but your licence expired a long time ago, there is no licence to move to your new device

  • Please explain/advise:
    In the Play Store I've got subscriptions for HD Traffic (next payment March 24) and the MegaPack (next payment December 23), and I use OSM maps.

    What exactly has "expired a long time ago" - and how do I get Navigator working (with those subscriptions!) on my new device?
  • please send logs and add your transaction ID
  • Sent an email message from my old device.
  • Problem appears to have been solved - I simply should not have transferred Navigator with a backup app, but reinstalled from the Play Store.
    Now I did uninstall/reinstall, and it works.

    Google even "warned" me that uninstalling would not end the two subscriptions (Mega Pack/HD Traffic).

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion