Test of Android version 3.0.x
  • 341 Comments sorted by
  • Same problem as chattiewoman: Android 7.1.1, MFN 3.0.43, hard- and software render as well.
  • Other bug: The scaling of the POI icons in hardware renderer doesn't work. They stay really minimal.
    In software renderer they are OK.
    Version 3.0.43

    Android 5.1.1
  • @hvdwolf : scaling works on Android 6 (HW+SW renderer)
  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 3.0.46+. The version will be on Google Play beta in few hours.
    -HW renderer crashing on restart engines fixed
    -Truck restrictions placing better
    -Truck restrictions for SW renderer added
    -Infopanel - satelites count fixed @mapper
    -Signpost and lane panels better placing @hvdwolf
    -Update of tts.xml @stavrich

    @chattiewoman(and others): The problem with night/day mode is more complicated that expected - it is needed to rewrite big part of Navigator.
    @hvdwolf: The problem with scheme editor can be connected with crashing of restart engines, so I think in this version it should work.
  • lubos mentioned:
    "-Signpost and lane panels better placing @hvdwolf"


    =D>
  • MapFactor Navigator ßeta version 3.0.46 Beta

    device: SM-T810 9.7''
    Map renderer: Hardware (experimental)
    Map UK 44-201612270

    Hardware 2D while simulating

    Departure Dover, CT16 1JA        lat:184061632 lon:4799552
    Waypoint: M42 from Dover        lat:188453530 lon:-6506942
    Waypoint: M56 from Dover        lat:192061750 lon:-9034454
    Destination: Holyhead, Llanfawr road    lat:191905868 lon:-16669312

    No labels showing, unexpected exit navigator when leaving Dover Docks
    Map renderer: Software runs fine.
    included 3 logs: 1st & 2nd run Hardware Accelerated & 1st run software (to compare against)
    1stRunHWaccel.zip, 2ndRunHWaccel.zip & 1stRunSoftw.zip (751 KB total)
    Will be deleted on 12 January, 2017
    Download link: https://we.tl/WDQ6wHKRhc
  • version 3.0.46, Software Renderer

    Two crashes/freezes today and unfortunately the debug level was on 2

    On the second crash the announcement went haywire repeating the next or last 3-4 instructions.   Below are the screenshots at the crash/freeze and the link of the two logs

    https://www.dropbox.com/sh/ekr2aw4lestsoa6/AACRhXt2Yh73d1NVui5FVQhCa?dl=0

    1st crash
    image


    2nd Crash
    image



  • This is outside this thread but I thought I should bring it to your attention
     
    Soon I will not be able to post images using my DropBox account as they will be removing the Public folder.
    The annoying thing is that any images posted to this forum via Dropbox will seize to be available after March.

    More than likely other cloud providers will follow suit.

    The safest way is to be able to upload images directly to the forum - can this function be enabled?
  • @chattiewoman - thanks and i should have searched before posting.

    Hope that an administrator can move my post to the 7579 thread.
  • @stavrich please provide routing points and vehicle profile for that crash(es)
  • Have been very busy and not had much time to test the latest build but I have been comparing HD Traffic reporting on Navigator with another app that also uses HD Traffic and am seeing a lot of missing reports on Navigator.  These are mainly road works that I know exist and are correctly reported on the other app.  Not sure about traffic congestion but will try to monitor this as well. The icons obviously still need sorting as it makes it very messy.
  • please give example
  • During last week the road bridge acrros the river Forth in Edinburgh was closed. I plotted a route across the bridge expecting a 35-40 miles detour but MFN with HD traffic plotted a 5 mile route across the bridge? It was a calculated route using the Tools menu & not an actual journey. HD traffic accessed from the Tools menu did indicate that the bridge was closed.
  • Saving selected POI categories doesn't work.
    I have only parkings and petrol stations selected. Now I'm on holiday and wanted to enable hotels as well. I can select them but my selection is not saved (and therefore not displayed).
    Navigator 3.0.46, android 5.1.1
  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 3.0.50+. The version will be on Google Play beta in few hours.
    -Advertisments on the end fixes
    -Crash on playing voice message fixed
    -Distance measuring fixed
    -HD traffic crash fixed
    -HW renderer crashes fixed
    -HW renderer freezing fixed
    -HW renderer icon size fixed @hvdwolf
    -HW renderer highlighted icons fixed
    -HW renderer load less distant geometry in 3D
    -HW renderer speed problems fixed
    -Opening map coordinate of maps.google fixed
    -User interface buttonbars missing texts fixed
    -Volume control of custom volume in menu and map only

    @Jan_Gruuthuse - try please last version
    @stavrich - I need logs on high debug to fix that crash but maybe we already fixed it
    @hvdwolf - problem with selected POI is only in hotels and restaurants(it is because these POIs are in more than one category). We are working on fix. About rendering icons in HW renderer, size of icons is fixed but zoom visibility is still incorrect
  • MapFactor Navigator ßeta version 3.0.50

    Unexpected exit still to drive 208 Miles 3:45 hours, could not eyeball exact location

    device: SM-T810 9.7''
    Map renderer: Hardware (experimental)
    Map UK 44-201612270

    Hardware 2D while simulating (speed x 10)

    Departure Dover, CT16 1JA       lat:184061632 lon:4799552
    Waypoint: M42 from Dover        lat:188453530 lon:-6506942
    Waypoint: M56 from Dover        lat:192061750 lon:-9034454
    Destination: Holyhead, Llanfawr road    lat:191905868 lon:-16669312

    Vehicule Parameters:
    Maximum speed 55.9 mph

    Unit system: Imperial (British)

    Optimisation Mode: Fastest
    Road Restrictions:
    * 60 Motorway                      
    * 50 Primary Road                  
    * 50 Major Road                    
    * 40 Secondary Road                
    * 30 Local Connecting Road         
    * 20 Local road Of high Importance
    * 15 Local Road                    
    only these are selected, all others are off

    ---------------------------------------------
    File (262 KB total) navigator_170117_164416.log.txt.zip
    Will be deleted on 24 January, 2017
    Download link https://we.tl/zzwWfRwnew
    ---------------------------------------------
    Update: Software render did finish the journey OK

  • Sorry, I didn't get back regarding problems with HD Traffic.  It is very slow in connecting and the majority of road work reports listed in the traffic report are not shown on the map.  Furthermore, the colour choices for indicating congestion do not stand out on UK colour scheme (yellow).  We should be able to change this as required. 


    imageimageimage
  • I was hoping for a response as to why HD Traffic takes so long to populate (don't have that with a competitor's product) and why road works are not displayed on the map.  Does the app take into account delays when calculating the route and is this included in the overall journey time?
  • what do you call 'so long'?
    I have them more or less instantly and visible

    yes, calculated route depends on traffic
  • imageimageIt can take up to 3 or 4 minutes for all traffic reports to populate with traffic queues being relatively quick but all others taking this time (see photos).

    You have not responded to my question regarding road works.  Why are these not displayed on the map?


  • please give example, roadworks are displayed on my device

  • Look at the photos posted, Tomas.  The only ones displayed are closed roads and not roadworks.
  • 3.0.50, onAndroid 5.1.1 
    I have been on holiday past week. The previous verion (3.0.46?) crashed twice.
    On the way home I tried the 3.0.50 version but I could not get TTS to work. I restarted twice but could only choose "silent mode" or "recorded voices".
    Another nav app worked OK with TTS
  • I can select TTS, but I have 3.0.53


  • I have 3.0.50 too, but my TTS engine (Google TTS) is still selectable.

    But I found another bug: Although I am using the Mega Pack, and it is still activated, I receive ads when I close Navigator. This was not the case in earlier versions.
  • 3.0.50 & Android 5.0.1

    I am using Google TTS which is working perfect 
  • @chattiewoman
    do you mean the full page ad?
  • Well, yes, it was full page. Right now I cannot reproduce it, shortly ago I could.
  • Ok, my ads are back again....
  • And this morning TTS worked fine again. Both yesterday and today after a fresh phone restart.

  • 3.0.50 Android 5.0.1

    Edit colour scheme...after editing and leaving the scheme list, Mapfactor is crashing.
  • @chattiewoman
    we cannot reproduce this, are you sure you can access premium features?
  • @tomas
    Premium features are working, just tested. However, the ad on closing the app still appears.
    Did you try to reproduce it with OSM maps too?
  • I tried with and without TT maps
    no ads
  • Tomas, sorry to keep asking but as HD Traffic is yet another premium, I need to fully understand and compare it with your competitors.  At present, only road closures and traffic queues are displayed on the map as far as I can see.  There are no roadworks shown on the map although these are listed on the HD Traffic page (which is slow in populating).
  • please click on a closed road in the HD traffic list and select Show on map
    some roadworks are displayed as slow traffic as road is partly open
  • I can click on roadwork links and show on map but they don't show as I posted previously.  I don't have a problem with closed roads or slow traffic, just the fact that the roadworks are not displayed even though they are on the list.  This, I believe, is a serious omission.
  • I need exact example, let me have coordinates
  • Really, can't you state whether road works are supposed to be shown or not?  I guarantee they are not - only those designated as closed and traffic queues are shown.  Try Gloucester, UK  which has a number of roadworks but only closed(?) roads and traffic queues shown. 

  • Can anyone who has access to HD traffic confirm if roadworks (not traffic queues or closed roads) are displayed on the map as I appear to be the only one testing this functionality.  Thanks.
  • Many thanks, hvdwolf, for confirming my findings.  Perhaps Tomas will now comment on this.
  • About the alternative sound output channel: when selected, if the phone is set in silent or vibrate mode, we have to increase the volume (and so get out of these modes) to hear the voices.
    And after closing MapFactor, we have to switch back to silent mode.
    This only happens with the
    alternative sound output channel; with the default one (media), we can change the volume without getting out of the silent mode.
  • 3.0.60

    Open colour scheme list or editing one. Crash is fixed. Nice
  • Just checked the latest build 3.0.60 and can confirm that Roadworks are now shown correctly.  The database is also updated a lot more quickly than before.  The only thing to be tweaked now is the size of the icons.  Well done, guys.

    What else has changed in this release?
  • 2 releases in 1 day.  Now on 3.0.61.  Any chance of a changelog so that we can test.
  • @lubos and @tomas: Is it possible to make the HD-traffic user-sizable? Like we can do for POI, road and text in the Map scale setting?
  • Hi Lubos and Tomas,  see these screenshots in HW render.  The icons are just too large.  Perhaps making them scaleable is the answer as hvdwolf suggests.

    I was also testing out the various Bluetooth options today and must say that the results were somewhat disappointing.  Can you clarify what each option is supposed to do (bar the last which is obvious).  My experience is that at times, it connected (ie interrupted my radio) but made no sounds or instructions (at the points in my route, I would not expect any).  It then sometimes connected with only part of the instruction transmitted.  I have set voice as Google tts.  Might I also suggest if tts is used then rather than sounds for the various warnings such as speeding and speed cameras, these are actually transmitted as voice instructions.  Much better than very short beeps etc.

    imageimage

  • @amlumsen

    Your Dropbox pictures are not visible in the foruom. However, I can see them when I call their address directly:

    https://www.dropbox.com/s/mith6o2y1bcrd8p/Screenshot_20170206-132835.png

    https://www.dropbox.com/s/jyne0wf9mj747k4/Screenshot_20170206-132904.png


    OK, now I do.
    BT works for me like it should. I am also using Google TTS, using the sound output channel = Use vehicle sound system over bluetooth.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Login with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter

In this Discussion