Test of Android version 4.0.x
  • Hello,
    the download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 4.0.9+ available for testing. If you need older 3.0.125 it is available at http://download.mapfactor.com/mapfactor_navigator_stable.apk.

    Or you can simply use Google Play beta system for automatic updates of beta versions at https://play.google.com/apps/testing/com.mapfactor.navigator.


    What is new
    -battery indication in infopanel (will be in build 4.0.10+)
    -coordinate format setting added
    -Offline fulltext searching
    -HD Traffic complete new implementation
    -HUD roundabout exit number added
    -HUD switching between normal and mirrored variant added
    -sharing gpx/nmea files fix

  • 9 Comments sorted by
  • Hello,
    Color schema deleted.
  • HD Traffic doesn't work properly. Today morning route to work. Incoming during navigation HD Traffic info is not displayed on map and not taken into account for trip calculation (no change in route or in estimated time of arrival) - it is only visible in menu 'HD Traffic' - so I knew that new info was properly downloaded (I've checked that when I was stopped by traffic jam not visible on the map). HD Traffic info obtained immediately after MFN (re)start is used and displayed properly - so for now it's not enough useful.
    Autozoom is not working at all (HW renderer)
    LG G6, MFN 4.0.9
  • Today I've changed renderer to SW LoRes. It seems (but i'm not quite sure) that in this mode HD Traffic works OK - much more traffic information was displayed during the trip. I'm not sure if everything works OK because typical jam i usually meet wasn't indicated today at all (on map and in menu) - so obviously there was no information in HD Traffic data. I've also observed appearing of alternate route calculated probably by HD Traffic engine (i have alternate roads set to off by now) indicated by slightly lighter colour (but there was any other info about this) - am i right with my assumption?
    Autozoom in this rendering mode works OK
    LG G6, MFN 4.0.9 
  • I'm currently updating my traffic_lights MCAs (see here).
    with the new 4.0.9 I do see them on the map in "view" mode, but I don't see them while simulating a navigation in hardware render. They are visible in software render in navigation simulation.

    And an old "bug" seems to have returned: The POIs in software render are minuscule and need almost maximum zoom. Fortunately the settings for the scaling between hardware and software render are separated, but can this scaling be aligned?

  • Today I've got an confirmation that with LoRes SW renderer HD Traffic works fine. I've obtained new traffic info during navigation - I was just before the traffic, so I've seen the change and I've got change in ETA and alternative route proposition (great job - really) which was a little bit faster. But... last weekend I've got longer trip and I've got a big problem with responsiveness of MFN after c.a. 50 km. With SW renderer I've got the same problem I had with previous version of MFN (last of 3.1.... I was writing about this in proper thread) and previous phone (LG K10) but even much worse. Refreshing of the map was partially divided (only part was refreshed), lag between current position in real and displayed on the map was more than couple of seconds which was equal to be around 100 m behind manoeuvre and still before on the map. Similarly responsiveness in HW mode after 50 km is also very poor (I have to wait very substantial amount of time for reaction on tap and even I need to repeat the action to get any reaction) but at least position and map refreshing works smoothly and OK. I presume that problem arise due to of much higher resolution of new phone's screen, because amount of memory, SOC and overall performance of the new phone (LG G6) is not comparable to old one. So for now I'm looking forward for version with HD Traffic fixed in HW renderer mode.
    During the weekend I was also testing Sygic nav. soft. to compare and I have to admit that MFN is for me much better in flexibility, usability, quality of trip calculation, and in many, many points - You are doing great job, but this problem of responsiveness is really big one - Sygic on the same trip has practically no influence on phone resources...
  • please send logs
  • MFN 4.0.24
    LG G6, Android 7
    No change in MFN behaviour - with HD renderer HD Traffic and autozoom don't work properly (as described earlier), with SW LowRes renderer all works OK. I'v set creating logs into "silent" (or whatever it is in English) and performance seems to be better (that was with version 4.0.9) - but so far i haven't got an opportunity to check new version with longer trip
  • the thread title "Test of Android version 4.0.x" mislead me. i am on Android version 6.0. Why shall we test old Android version? The newest is Android version 8.1, Oreo

    Or did you mean MFN4.0 beta (for Android smartphones)?

    Anyway i was mislead since my start on the forum, beginning of March. Until today. Thanks.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Login with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter

In this Discussion