Speed Limits Not Showing Up
  • I am using the Android version of Navigator and I am having troubles with speed limits. When I drive on a major interstate the speed limit shows up on the screen but whenever I am on normal state, county or city streets no speed limit is displayed. In looking at the manual it also appears I should be able to configure for the speed limit to show in one of the bottom information boxes, when I attempt to configure this there are lots of options but speed limit is not one of them. Any ideas on how to fix this?
  • 2 Comments sorted by
  • speed imits are frequently missing in free maps, that is why you cannot see them all the time

    Free maps are created by volunteers at www.openstreetmaps.org - anybody can join and help to make maps better using their local knowledge. May be you can also contribute?
    You can also buy TomTom maps (Map manager/buy maps).

  • Hi Tomas,

    I have had the a similar problem with OSM-maps... 
    Today I drove through Hamburg on the way to the target I used the navigation mode, speed signs where shown. everything works.

    On the way back fist I used the the "show map only mode"... no speed signs where shown. After half of the way I startet navigation to my home and directly after calculating the route the seep signs whre back at the screen. 

    When I look to the OSM-data, all dtasets for the roads I drove today have a correct speed limit setting in OSM online editor. 

    I think it's important to show the speed signs in the map also in the "show-only-map-mode" and not only in navigation mode.

    Regards
    Michael 

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Login with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter

In this Discussion