strange behaviour in Navigator free Android




  • hello,
    i noticed a strange behaviour in the Android version of Navigator Free: 2.0.30.DEVELOP (downloaded from the "Play Store")
    i have converted 30 POIs from .csv to .mca with Digger , the problem is within
    the Camera alert POI selection: i have more than one poi that i want to be alerted when near.

    what I do

    1. settings -> Camera -> place a check-mark (the blue "V" like symbol) on some POI to be alerted when near it
    2. scroll down the list (the first POIs disappear from view) to check some other POI
    3. scroll back up and the check-mark on the POIs that disappeared from view because of the scrolling action are now on OTHER POIs which
        i did not initially select!
    if i go back with the "<--" button without scrolling the screen then the selection is preserved
    but every time i scroll the list to select/deselect some POIs, the POIs that have the "V" blue check-mark change randomly!


    example:

    the phone screen is represented by lines (---------)
    -----------------
    POI_A
    POI_B       v  <--- i have selected those two POIs
    POI_C       v  <---
    POI_D
    ----------------

    scroll down with finger...
     
    -----------------
    POI_D
    POI_E       
    POI_F       
    POI_G
    ----------------

    scroll back up...

    -----------------
    POI_A        v   <-- the selection have changed !
    POI_B       
    POI_C        
    POI_D
    ----------------

    Does someone else have this problem ?
    thanks in advance!



    INFO
    version of Android: 4.4.2, kernel: 3.4.0+
    version of Navigator Free: 2.0.30.DEVELOP
  • 4 Comments sorted by
  • this is a known bug, which has been fixed - please wait for the next version
  • hello, I updated today to version 2.0.33-master from Google Play and I have the same problem, what is the version number with this bug corrected?
    thanks
    PS: is there a way to manually configure the camera alert POI selection via editing a configuration file (without using the GUI interface that has a bug)? in this way i could begin using my POI while waiting for the updated program...
    i have seen some .xml files but in none of them i have found a reference to the selection of POI for the camera-alert function
  • Move all no needed for speed cameras selection poi.mca files to another folder. Run Navigator, settings ...camera... and set it, without scrolling down. Check result - should work, so close Navigator and move back poi files. Now run Navigator again and check if all works - all POI should be on the map and all speedcameras/POI alert, don't go to settings/camera....

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Login with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter

In this Discussion

Tagged