Constantly says to take sliproad off of highway just to go back on the highway
  • Something that I've found particularly vexing with Navigator is that it constantly takes the slip road when I'm on the highway. I have to place waypoints all over the highway just to make sure it stays on the highway. Maybe this is because Navigator is attempting to plot the shortest distance between two points. Something that I know Google does with Google Maps is that it gives the option of a number of different routes between two points that the user can choose. Those routes, if there are highways, keep the user on the highway as long as it can until it reaches the destination. If the user decides to take a side road, it will reroute once the user has reach a particular distance from the highway and give the user a completely new route to take.
  • 112 Comments sorted by
  • Hi to all. I'm using Mapfactor Navigator free 14.1.2 with OSM maps. I got the infamous bug regarding the sliproads. As a work around I just changed the roads allowed in the car setup by unticking all the local roads.
    The bug seems to be corrected with that trick. I have checked that locations needing to go through local roads are still available and found during calculations. Doesn't seem to change anything in terms of navigation.
    Just my two cents.

    BTW, if you need to navigate in France where it is not allowed to use a GPS displaying Radars but only 'zones de danger' (funny frenchs isn't it...) you can get a file by searching 'lufop' on the net. You will acces a file in csv format but a tool is provided for doing a conversion. It lloks a bit tricky at first but it isn't. Just use the files for France as the other ones are duplicating some part of the cameraspeed and camera light data.

    Have a nice trip.
  • The biggest issue currently is that in the map creation there is no separation between higways (motorways, autobahn, etc) and its sliproads/ramps/exits: They are equal with equal priority. There is no way currently to make a separation between them in the settings. This IS the issue. You can't influence this with the settings.
    The result is that sliproads/ramps/exits get priority over motorways where the motorways have a speed tag below the maximum speed and where the sliproads don't have this setting.

    Putting highways to 70% or higher is actually not a solution at all as both the highways and the sliproads/exits/ramps also get the 70% priority (Next to that: you dramatically bias the routing algorithm resulting into bad routing calculations over all). This really is a flaw in the routing algorithm of MNF.


    MDX recently created a special map where he overrides the OSM original settings in the map by simply setting the sliproad/ramp/exit speed to 50% of the highway itself. That definitely helps but is not a solution: it's a work around.

    The only proper solution is to give sliproads/ramps/exit their own priority, not only for highways but for all roads. It could be a (sub)setting in the profile settings (sliproad/ramp/exit 50% of main road) or hardcoded in the routing algorithm (if "sliproad/ramp/exit", set priority to 50% of highway priority)

  • Please forgive me but how does the above routing issues tie in with the Slip road issue?
  • I  have one strange example showing the sliproad problem.

    Galaxy  s4 GT-I9506 android 5.0.1
    MF vers.  08.38.90
    Default car settings except Motorway  “Use speed restrictions” unchecked, and "Small Local Road" enabled.
    Routing mode: Fastest
     
    Departure: Denmark - Hobro – towncenter
    Destination: Denmark – Langeskov – towncenter

    Calculate route and have a look at 55.68316, 9.56394

    Then you can see MF navigate by the sliproads as expected, looking at this discussion, but of course it is bad.
    But the strange shows up when you put a waypoint in at 55.73133,  9.57571 (as an example). Now MF remain on the motorway. As far as I can see, the problem occurs when the distance between the navigation points are too big.
    If I disable small local road it is also ok, but there ar no small local roads here.

    I see the same problem when I try to do the same with Windows7 and MF 14.3.2.
  • Hello everybody,
    I tried to read through this topic (and I will have to re-read it "one day"). Please try the simple "workaround" how hvdwolf named it ... with speed reduction for sliproads (all OSM maps released since today). It should help as all average speeds are some estimates.

    There are several colliding requests - I would wish for separate vehicle profile settings for OSM maps. The number of categories and "speed categories" is very limited (one byte for all including "urban flag" which will be tested on czech_republic_osm this Jun 2015 data) - on the other hand precise speed description caused even more problems (accidentally used also for OSM maps in Dec 2014 as far as I remember).

    thanks
       Martin

  • @crcook84
    /I found the car profile.../
    1. YES! That's right.

    2. Please don't copy Google maps/base to OSM.
    More useful info on forum: http://forum.openstreetmap.org/
  • What's more: It is not allowed to copy from Google Maps to OSM!
    It is illegal according to Google AND it is illegal according to OSM legislation.
    Don't do it!
  • a) use www.mapillary.com, more info - http://wiki.openstreetmap.org/wiki/Mapillary
    b) own survey :)
  • We have that topic already a couple of times here in the forum, just recently another one. You are absolutely right. This is still a major bug of MFN.
  • may be you are using pedestrian mode?
  • I agree with Tomas. It is exhausing as a pedestrian to get of the highway, run up the exit and down on the ramp to the highway again before you can continue your walk on the highway. Especially with all those stupid cars around you  :)

    But indeed: this serious bug has been reported multiple times and is still not fixed.
  • I think that crcook84 is descrbing something else

  • "when I'm on the highway". As pedestrian? Never!
  • if you set pedestrian mode and are on highway, then it will force you off at the next exit - if you continue on highway, it will again force you off
    I think that is what he is describing
  • I am in agreement with Oldie and crcook84. This weekend while in Edmonton Alberta Canada, we took a trip to the West Edmonton mall along the freeway of Whitemud NW and there are about four (4) slip roads that MFN indicated to take and then immediately redirects you back on to the freeway. The mode type that I am using is car. It would be great if this could be fixed, wherein if you are on the freeway that it does not direct you to take all the slip roads on the journey to your destination which are unnecessary. Also, thank you for a great navigation tool.
  • I agree with you, but I do not think that this is what crcook84 is describing
  • Change motorway preferences to 69 and check result.

    Almost the same issue with motorway exit.
    From 51:2:42,72 16:58:14,592
    Via 51:2:53,8 16:58:18
    To 51:2:42,612 16:58:55,344
    It seems to be fine, but without 'via' routing looks like Disney's fairy tail Duck Donald on motorway.

    (edit)
    Works fine with charge and toll roads.
  • I get the same with or without waypoint with 50% or 69%
    not sure what are you referring to
  • Higher preference of motorway should help to stay on highway road (for crcook84).

    The next case - try disable charge and toll roads.
    I add some screenshots soon.
  • a little crazy :-) but I have no idea which one is toll/charge road, so it may very well be the only way
    yes the 'ignored' slip road is marked as toll road, others are not, so route. I think is correct
  • This is not the case with the trip to West Edmonton Mall. Even with the Motorway as the only active selection in Road Restrictions and the route mode as Fastest with Car type, MFN still chooses the Motorway link. I checked the route in OSM and the path and exits are marked correctly as Motorway for WhiteMud NW and Motorway Link for the slip roads.

    Try these coordinates.

    Departure - Whitemud Drive Northwest, Edmonton, AB T6P 1T6, Canada Latitude: 53.483028 | Longitude: -113.356896

    Destination - West Edmonton Mall Transit Centre, Edmonton, AB T5T, Canada Latitude: 53.520389 | Longitude: -113.622528
  • this is another case
    there is a speed limit 80 on the motorway, but none on slip road
    result is that fastest route is on slip road
    this does not happen with TomTom maps
  • Reffering to this 'crazy' routing.
    Yes, this is the key.
    Destination point is on toll road, with paid road disabled, and routing try avoid this paid road as much as possible.

  • @WillyJ - if you would like to test experiment with the speed_average set to half of the original value for sliproads here is the revised MCA: http://download.mapfactor.com/canada_alberta_osm_150529_exp150615_cc5b3e8a7c.mca
  • @mdx - I tested the 'canada_alberta_osm_150529_exp150615_cc5b3e8a7c.mca' and the change you made with the speed average set to half of the original value for sliproads works. The route stays on the highway instead of choosing unnecessary sliproads. Thank you.
  • Sliproads mean what for the US settings?
    This is the biggest drawback that keeps me from using this app.
    After about 45 min on the interstate I have to switch to another app.

    Where do I find this setting?
  • you can set American sounds, or TTS in Settings/languages
  • @Dave Did you really bother about sounds? Or more about routing?
    @tomas Do the sound settings have any influence on routing?
  • sounds have no influence on routing, Dave is complaining about British language
  • I disagree, he is complaing about routing (as @crkook84 did at the beginning of this topic - and not as  pedestrian ;-) )
  • may be he can clarify, but why does he write

    Sliproads mean what for the US settings?
  • I agree with you, but what you suggest is also workaround
    best would be to have speed limits everywhere (like TomTom)
  • My suggestion is not a work around. Both in the Netherlands and in Germany (and probably elsewhere), you have motorways with separate parallel lanes with exit and access ramps. These motorways and parallel lanes really have the same speed tag. These parallel, mostly even double, lanes are not for the normal ongoing traffic, but to safely and comfortably let drivers exit or access the motorway. If this motorway is curved and the parallel exit/ramp lane is the inner curve MNF routes you over these parallel lane, as it is slightly shorter. That should not happen.

    If you say that Tomtom is correctly speed tagged and uses these speeds then MNF makes the exact error with TomTom maps as with OSM based maps. Maybe less due to the more correct speed tagging, but not in the situation of my example (which occurred 4 times on my ski travel last winter).
    You have even provided a good argument to improve MNF with regard to this "bug" as it also inflicts the TomTom maps.
  • please provide example
  • My question was for routing.
    When I use it to get from 1 place to another, it very often tells me to take sliproad.
    What is a sliproad?
    The first few times it told me to take a slip road I did, It was a exit off of the interstate.
    At the end of the exit it told me to go straight.
    Right back onto the interstate. It did this over and over and over again.

    Above my post of last night (WillyJ) it was said that giving slip roads a lower speed helped solve
    that problem.
    What is the setting for sliproad speed?
    What is a slip road?

    Dave.

  • slip road = exit road, it is British
    you can change to American sounds in Settings languages

    at this moment you cannot change speed for slip roads, unless you edit OSM maps

  • Ok,
    Thank you Tomas.

    How did WillyJ do it then?

  • I have had this problem in the UK though it's usually associated with motorways. I agree with hvdwolf. It would be better to give slip roads exit roads etc. their own settings of 50% of the parent road thus forcing MFN to stay on the parent road.
  • @Tomas:  "please provide example".

    Come on, there are other relatively new topics about the exact same issue where multiple users, including myself, have added images: Oldie also refers to it in the second post of this thread. How many examples do you need to finally understand that this is an issue?
    Not only users should search the forum, supporters should do likewise.

    Edit: but if you need an example. Look here and here
  • Thank you Mr. Wolf.
    Your first example is spot on and exactly
    what I am experiencing.
    When you are in a strange city and it tells you to 
    take the slip road do you or do you not?

    Do you change lanes or do you not?
    It is NOT safe too look down and see you have to make a blind choice.

    If you think it is bad in a car try it on a motorbike.
    After a few times you figure out that it is not worth it any more.

  • @Dave - I did not make any changes, it was MDX who provided an updated Canada_Alberta_OSM.MCA file for testing purposes. The change he made by defaulting the speed average set to half of the original value for sliproads worked for the test MCA file of Alberta that he provided.
  • @hvdwolf
    yes, and there are many examples with incorrect vehicle settings, if fact a lot with pedestrian mode

    your first 'here' - with default car settings my route does not use slip road
    does yours?
  • @tomas , I see a lot of users that are complaining about routing problems... Motorway Link, Trunk Links, Primary Links, Secondary Links, Tertiary links, tertiary roads your are using them with the same priority like residential roads, etc.....

    I can't understand why you are not changing and revising the routing algorithm, and roads category priority in MapFactor.

    Roads category is messed up. If in your area , or in your country maybe it's ok, in another country is not.
    This is the only navigation software that uses "fine tunning settings" for road priority, with speed settings etc.... How many users knows and have time to test the settings to make the software to give a good route. Do you have that time in traffic ?!?! I don't think so ....

    In OsmAnd I didn't had any issues in routing and it does not use "advanced routing settings" like MapFactor.
    Be-On-Road, work very well with all tests I made.  Scout the same......  None of this software , uses those settings, that for a lot of users, are difficult to understand. 
    Difficult to understand also because of the road category integration in category road in routing settings. So messed up. Keep in mind that TomTom uses 4 or 5 road classes FC1-to FC4 or FC5, the same Here does (routing priority only from FC1 to FC3, but OSM uses a lot of roads category for road transit and priority( OSM uses 5 and also we have "Links" for that every roads.. so OSM uses FC1 to FC5 for routing purposes) . You gave the motorwary, trunk and primary links to much priority. Tertiary roads has the same priority like residential roads... You associated the roads in wrong category groups ....

    For example I'll give you the same example in Bulgaria.. If a primary road is closed for cunstruction because they are upgrading them for Motorway, MapFactor does not want to route through the nearest 2 continuous tertiary roads, and make a detour of almost 350 km longer route , no matter settigns I made. No other software had that issue, because they were able to route through tertiary roads. I had to drasticaly change the road category to "help" MapFactor to route well in Bulgaria ! They have a lot of Secondary and Tertiary roads used for transit ! Primary roads arer often closed for motorway upgrade ! Same issues in Greece !
    Also keep in mind that not all countryes has the same roads structure and road classes in OSM Data. How many km of roads are in France or Germany with Trunk roads, and how many in Greece and Bulgaria ?
    Here in Romania, we upgraded a lot of roads from Primary to Trunk, all roads that has European Roads tags on them, have 4 lanes in total or 2 big lanes, very good paving, and are very good for transit ! You'll not see this in Bulgaria for example and in other Eastern European roads !

    So...... Have you considered ,to rethink the routing in MapFactor ? For the moment a lot of users are keep  telling you that there are major issues with the routing, and maybe a lot others that they don't know or don't give a damn about the software, and they will never create a forum account to start a disscution or give a feedback on Google Play Store.

    I don't want to be rude or misunderstood, but like others I like the software and I want it to perform better !

  • well, you are right in some points - our categories do derive from TomTom maps and that is certainly cause of some problems. It is on our list to split OSM and TT in this sense, but we need to find time to do it, it is not as easy as some would think

    however, my point is that slip road detours would not be issue if speeds were correctly applied in OSM - with TomTom maps it does not happen
    I can fully understand why mdx is reluctant to implement workarounds, as these usually create problems elsewhere. Take for example half speeds, which someone tested in Canada - speed can be reduced too much and routing could be wrong somewhere else

    as to your secondary and tertiary roads in Bulgaria - as far as I know these are used in default car settings, may be ptovide departure and destination, I will check

    lastly, I am not a programer, mdx could give more details, but he is away this week



  • No problem ... we can wait ....

    In my last example for Bulgaria, a route from Bucharest ( Romania ) to Katerini ( Greece ).
     A route will be from Bucharest ( Romania ) through Giurgiu ( Romania ) , Ruse ( Bulgaria ) , Pleven, Sofia, Blagoevgrad, Kresna, Kulata ( Bulgaria ) and then to Greece on Highway near Thessaloniki, to Katerini.  

    And from south of Novo Delchevo to Kulata the E79 is closed for motorway upgrade and MapFactor should give a route through 2 tertiary roads ( one from Novo Delchevo to Petrich and another one from Petrich to Kulata ). Map Factor is unable to give a route through Tertiary roads no matter settings you'll made.  
     I rised the priority for that roads from Tertiary to Primary until the Motorway upgarde will be done !

    Because MapFactor is unable to route through Tertiary roads, it wants to make a huge detour from Sofia to Plovdiv, Haskovo, Kirkovo then Komotini in Greece, or  through Haskovo, Svilengrad  and then Greece near Edirne from Turkey border ! This detour causes 400 km longer route than expected.  

      I've tested the route settings for more than 4 hours in total....  MapFactor will not give you a route through Petrich to Kulata, because is unable to route through tertiary roads.. It will give you a route if there is a destination on a tertiary roads, but will not route through tertiary roads if, we have a long route !
    Maybe it's a fault and tertiary roads is in residential roads group, and has the same priority.
    You can make a change in road groups to use it almost like TomTom road classes.
    FC1 - Motorway
    FC2 - Trunk and Primary
    FC3 - Secondary and tertiary
    FC4 - Minor Roads, Residential, Service roads, Living Streets, Unknown roads .

    so with this one you'll use the roads priority and category like TomTom does, and we can test that in a beta version. 

    Or the hardest way, you'll have to use two different routings scrips where roads category is defined , one for each type of Maps... TomTom or OSM !


    ;)
  • Another one with 5 road classes from Here. I've talked with one of the guys from there ( Geographic analyst II

    Regional Map & Content ) 

    He made a side by side comparison between Here and OSM roads classes !

    FC1 - Motorway
    FC2 - Trunk
    FC3 - Primary
    FC4 - Secondary and Tertiary
    FC5 - Minor Roads, Residential, Service roads, Living Streets, Unknown roads .

  • I am not sure what do you mean, if I put waypoint on the main road near Novo Delchevo, then I get route on A25, 765km long - I think this is what you want



  • @Tomas: Indeed. You are right. My first mentioned example does work now. 
    I checked the history of the changes quickly, but can't find what changed in the tags of these roads to change the behavior of MNF. The tagging was correct and is still correct. This really puzzles me.

    It makes it even stranger: you can clearly see from the image that MNF calculated the wrong routing. I can't find any change in these roads that explains why MNF is now calculating it correctly. Did you find anything in the OSM data that explains it?

    So the other question is now: what did change in MNF or what did change in the map creation, as the data in OSM does not explain this change in behavior.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Login with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter

In this Discussion

Tagged