Test of Android version 1.4.x
  • Hello,
    the download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 1.4.17+ available for testing. If you need older 1.3.43 it is available at http://download.mapfactor.com/mapfactor_navigator_stable.apk

    What is new?
    Bugfixes, translations, intents of more supported applications, new toolbar, ...
  • 99 Comments sorted by
  • Try install tts program with Your voice, Google tts, or IVONA.
    Then try change to Your voice.


    (btw)
    In polish translation in 'Search' menu ..., in 'del from history' should be "Usuń z historii szukania".
  • OK. I found solution. I had turned off "text-to-speech" plugin under Android programms. Maybe you have to insert some check for this plugin. Thank you PrzemekSupak . You gave me idea to that.
  • Hello, it's me again.

    Today I've been able to make some screenshots of the left program portions. The are two tasks left in memory both occupy about 2.4MB each.

    https://www.dropbox.com/s/u4misk97fhvygoq/Navigator active.jpg?dl=0

    https://www.dropbox.com/s/0gxiwewrv2ilov9/Navigator memory.jpg?dl=0

    As mentioned in my last post I update the maps manually - so what's going on here :-/

  • What do you mean by "new toolbar"?

    (my corrected french is gone... ;)
    Edit: and now back in 1.4.18)
  • clik on the map, you will see
  • Oh yes thanks! It's now much easier to touch the icon I want. :)
  • Thumbs up on the new toolbar!
  • Well done for the toolbar.
    With this version, I could also move the maps to the external card very easily even with Android 4.4.2.
    The previous version of Navigator didn't recognize the external card at all
  • 1.4 looks good. But I still miss informations for turn lanes exept them tagged in OSM as turn:lanes:forward=*. And even they doesn't appear from their real beginning, if roads in OSM must have been splitted because of a bridge or turn restrictions  :(
    (example: https://www.openstreetmap.org/way/23881586 and the two next wayparts southward)
  • @hurdygurdyman - the lanes are related to data & data conversion process (so when further implemented it should be visible even in older versions)
  • program crashes when loading stored GPX tracks...

  • ...does not happen with NMEA tracks...
  • it works fine for me with both formats
  • @mdx
    thank you for information. Im looking forward to see all the turn lanes.
    By the way:
    In German OSM-forum we have started a "weekly task" to get more and more turn lanes tagged until the end of next week.
  • @ualios - can you send us crashing GPX? Maybe the best would be "Send logs" and attach there also GPX. And please add description "crashing 1.4.x, forum"
    thanks
       Martin
  • New toolbar is handy, would be nice to have an option for showing/not showing text below icons.

    Some spanish strings make toolbar take almost half screen space... for example "Buscar el más cercano" (Find nearest) instead of, say, "Buscar POIs" (Find POIs), and so on. Those strings need to be shortened in all translations to avoid this glitch.
  • @mdx  ...back to stable version and same problem!!

    Finally I had a look to gpx dir and found many gpx files... each 364 byte large and no trackpoint recorded inside:

    <?xml version='1.0' encoding='UTF-8' standalone='no' ?><gpx xmlns="http://www.topografix.com/GPX/1/1" version="1.1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.topografix.com/GPX/1/1 http://www.topografix.com/GPX/1/1/gpx.xsd" creator="com.mapfactor.navigator"><trk><name>2014-10-29_11-02-55.gpx</name><trkseg /></trk></gpx>

    Now I can confirm that app crashes when loading a file like that. No problem with gpx file with at least one trkpt recorded.

    So everything's OK... but still don't know how I got all those gpx empty file !!!

    P.S. If needed I can send log files.


  • - uploaded version 1.4.19 - there is an attempt to fix extra long names in toolbar & romanian TTS from GabrielMoise
    - @ualions - I can confirm the crash for empty GPX (it is not fixed yet, in this version)
    - I forgot that in 1.4.x is new settings "Map language", where you can choose your application language, original name or English
  • Wow, now Laun is Louny (and others) and I will find my may in the Czech Rep. :-D

    The menu in German could be:

    Kartensprache

    Wählen Sie die in der Karte verwendete Sprache

    And for the following three options:

    Anwendungssprache

    Landessprache

    Englisch

    And for "use compass"

    "Kompass benutzen

    Kompass zur Anzeige der Richtung einblenden"
  • I am unable to switch the application language two times in a row (without closing the app in between) because the app will crash on each second try I click on Settings --> Languages.

    The log is saying at the end:
    DMP 14/11/22 13:44:36  (JAVA) MapActivity::onRestart()
    DMP 14/11/22 13:44:36  (JAVA) RtgNav::activeProfileName()
    DMP 14/11/22 13:44:38  (JAVA) MapActivity::onPause()
    DMP 14/11/22 13:44:38  (JAVA) Map::mapColorSchemes()
    DMP 14/11/22 13:44:58  (JAVA) NavigatorApplication::onLowMemory()
    DMP 14/11/22 13:45:02  (JAVA) SOUND: TTS engine - no voices available
    ERR 14/11/22 13:45:02  (JAVA) java.lang.NullPointerException
        at com.mapfactor.navigator.preferences.LanguagesDlg.finishCreate(LanguagesDlg.java:206)
        at com.mapfactor.navigator.preferences.Preferences.onActivityResult(Preferences.java:536)
        at com.mapfactor.navigator.preferences.Preferences.onCreateDialog(Preferences.java:654)
        at android.app.Activity.onCreateDialog(Activity.java:2955)
        at android.app.Activity.createDialog(Activity.java:968)
        at android.app.Activity.showDialog(Activity.java:3048)
        at android.app.Activity.showDialog(Activity.java:3007)
        at com.mapfactor.navigator.preferences.Preferences$14.onPreferenceClick(Preferences.java:332)
        at android.preference.Preference.performClick(Preference.java:951)
        at android.preference.PreferenceScreen.onItemClick(PreferenceScreen.java:215)
        at android.widget.AdapterView.performItemClick(AdapterView.java:298)
        at android.widget.AbsListView.performItemClick(AbsListView.java:1086)
        at android.widget.AbsListView$PerformClick.run(AbsListView.java:2859)
        at android.widget.AbsListView$1.run(AbsListView.java:3533)
        at android.os.Handler.handleCallback(Handler.java:615)
        at android.os.Handler.dispatchMessage(Handler.java:92)
        at android.os.Looper.loop(Looper.java:137)
        at android.app.ActivityThread.main(ActivityThread.java:4802)
        at java.lang.reflect.Method.invokeNative(Native Method)
        at java.lang.reflect.Method.invoke(Method.java:511)
        at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:813)
        at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:580)
        at dalvik.system.NativeStart.main(Native Method)


  • I was coming from a newer version than 1.4.19, so maybe the following issue only affected me. Maybe others could check it too.

    After the update (or better: downgrade) to 1.4.19, my (recalculated) Itinerary looked like this:
    image

    Only after changing the system language (or was it the restart due to my app crash mentioned one post earlier??) the Intinerary was fixed:
    image

    By the way, please fix "Weiterhin für [distance]" with ... er .... maybe "Noch [distance]".
    Any better suggestion from a German "colleague" here ...?
  • Vielleicht:  "(etwa) [distance] folgen"
  • Yes, "[distance] folgen" would also be OK.
  • Thanks for bug reports - now the link points to 1.4.20+
    http://download.mapfactor.com/mapfactor_navigator.apk
    - language dialog should be fixed
    - local names (bug with '|||') should be fixed
    - used Oldie German translation
    - empty GPX import should be fixed
    thanks
       Martin
    p.s. "folgen" is not fixed - I am afraid that the text is first and then distance - TODO
  • 1.4.20:
    The language dialog does not crash anymore, but after having selecting another language and having reopened the languages dialog, fields "Voice engine" and "Download more voices" remain empty; nothing can be selected.
    I waited extra long; the fields really won't load. I have to restart Navigator in order to make it work.

    In the map Toolbar, German translations are missing:
    "Edit Link" = Verbindung bearbeiten
    "Add Favourite" = Zu Favoriten hinzufügen

    The preinstalled vehicle profiles (Pedestrian and so on) are still in English, whereas the +-buttons at the bottom are translated.

  • for me Download more voices works fine

  • Bug or feature?

    I just encountered the following bug/feature during travelling.
    When using "destination:lanes" you get the nice blue road sign on motorways in the top-left of your screen (see Google Play).

    Say, we have two ongoing lanes without specification and one exit going to Berlin (for example).
    The allowed ways to do this are:
    destination:lanes="||Berlin"
    or
    destination:lanes="through|through|Berlin"
    As mentioned both is allowed.
    Currently Navigator displays the blue sign with "through" and an arrow straight on (if it finds through). It means that it treats "through" as a city.
    I would say this is a bug (especially for non-english speaking persons), but some might find it really handy.

    How to deal with this?

    Edit: version 1.4.20
  • v1.4.19
    1. In the main menu when I scroll menu, menu color blinks between Light-White and Gray-White. Looks like incorrect color is chosen for text background.

    2. When you add new waypoint to route, background for Start point is transparent in the "Select waypoint position" window. Not sure if it is expected behaviour because text of start point is not readable.
  • Dmytro can you post screenshots/video?
  • 1. it does not change colour for me
    2. I have one waypoint highlighted in blue - do you have mono screen?
  • It is Android 2.3 problem, I'll fix it.
  • 1. Standard menu color: https://yadi.sk/i/4xBhivIlcxVTV
    menu1.jpg has standard color. menu2.jpg has non-standard color
    It changes color. You can check it in the photoshop or other image editor.

    2. What is "mono" screen?
  • 2. black and white


  • be patient, lubos will fix it
  • Version 1.4.21+ uploaded (http://download.mapfactor.com/mapfactor_navigator.apk)
    - added some translations (cs,ru,ro) and fixed problem with colors on Android 2.3
  • Could somebody else please try to reproduce the languages issue? You will have to change the language setting two times in a row.
  • @hvdwolf - can you please point me to specification where "through" keyword is recommended? thanks
    Edit: + give me way ID where you have seen it please
  • @chattiewoman

    For me it is not possible as well to change "Application language" more than one time in a row. When changed one time and opened the dialogue again, the ok button is grey and not full colour. It becomes only full colour again after closing the app and starting again. This seems to be intended behaviour. I could live with it, because I will not change that setting over and over.

    Of course more elegant is the solution, when changing map language. On that change the app restarts itself automatically.
  • >> fixed problem with colors on Android 2.3
    affirmative
  • Please add option to name Waypoint upon creation.

    Sequence:
    1. Tap on the Map => Side bar appears with "Waypoint" button
    2. Tap on the "Waypoint" button
    3. Window should appear with the name of Waypoint in the text box and buttons OK and Cancel
    4. Waypoint with provided name should be created

  • Hi Dmytro,

    What you describe is a favourite. That is the bottom option of the side panel. The "Waypoint" is really like a temporary waypoint which you want to use in your navigation.
    If you want to store it with a name use the "Add Favourite" option.
  • Hi hvdwolf.

    For me favorites is something like a permanent place. Like Home, Work, Supermarket or any other place you visit very often. Waypoint is something temporal, which you are going to visit and after it is visited you switch to another one.

    Why I ask about this functionality is because when I add many wayponts (for example Castle XXX, Monument YYYY) Navigator assigns name which sometimes means nothing for me. When I read my route I do not understand where am I going to go.


  • Yes, you are right but not entirely.
    If you create a waypoint (or route point) it automatically gets the name of the street or the name of the POI.
    When you are in the "Route Information" screen and you tap a waypoint you can also rename it.
  • Sometimes you have to add waypoint near the POI because POI is not reachable by car. In this case name of waypoint will different

    If you want to optimize waypoint creation and do not want to introduce extra window, you can add Rename waypoint button to the Side bar (near Delete waypoint button).

    Also you can add "Name" text box to the Search POI by coordinates window.
  • During my last trip with navigation enabled, Navigator suddenly lost its tts voice: the navigation ran fine, just the voice was missing.
    Reason: I have no proof, but I think this was triggered when I received a phone call on my device, even though I rejected it.
    Resolution: App restart did NOT help. I had to open the language settings (without the need to change anything), and click "OK".

    Very strange.
  • @mdx: You wrote to me "can you please point me to specification where "through" keyword is recommended? thanks
    Edit: + give me way ID where you have seen it please"

    It took me quite some time to find the way id back (busy traffic and I assumed I would simply remember).  Just because I saw the "through" I was so convinced that it was an error, that I also mentioned it like that. But I was wrong. 
    It is not allowed in the destination:lanes.
    Anyway; after I found the way id back I corrected the incorrect destination:lanes and removed the "through".

    So this is not a bug in Navigator but an error by me (and the mapper of course).
  • @chattiewoman , i think it's related to the volume. In my case, when I receive a call, the tts volume of navigation is set to low, or mute. After the call ends, i have to push the volume up button on phone, to regain the volume as i want for the app.

    Have you tried this ?!?!?

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Login with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter

In this Discussion

Tagged